Rayrun
← Back to Discord Forum

Can't found element, which is present on the page, but has some strange "hidden" status

vladislavgoogleposted in #help-playwright
Open in Discord
vladislavgoogle

Hey everyone, I have a problem finding an element on Wikipedia's "User Profile" page. I have to choose one of the language options of the "Language" <select> element. However, the Playwright seems to recognize this element in the DOM, but can't see it because of some "hidden" status. Am I doing something wrong? I would be grateful for any help because I have already tried everything

image.png
image.png
image.png

This thread is trying to answer question "Why can't Playwright interact with a select element on Wikipedia's 'User Profile' page, despite the element being present in the DOM?"

2 replies

Did you try to record it ( select it ) with codegen and see what is using there

vladislavgoogle

You mean, did i use the "Pick Locator" feature in debug mode? Yes, i tried it, but for some reason, exactly on the "User Profile" page, pick locator doesn't work (it doesn't highlight elements at all)

Related Discord Threads

TwitterGitHubLinkedIn
AboutQuestionsDiscord ForumBrowser ExtensionTagsQA Jobs

Rayrun is a community for QA engineers. I am constantly looking for new ways to add value to people learning Playwright and other browser automation frameworks. If you have feedback, email luc@ray.run.