← Back to Discord Forum

Issue: Command failed: npx playwright install

neverlegendposted in #help-playwright
Open in Discord

I'm currently trying to learn playwright and so far im just running to this issue where when i do the following command "npm init playwright@1.17.123" it loads everything up perfectly fine but im getting this error message: "Command failed: npx playwright install" i tried looking the googles but all im getting is cleaning "apt cache". I've done that but nothing has changed. Can anyone help?<:playwright:1054714813638516757>

This thread is trying to answer question "Why is the command 'npm init playwright@1.17.123' failing with the error message 'Command failed: npx playwright install'?"

6 replies

That is rather an old version. Try using @latest. If that doesn't work we can look deeper.

So I’ve tried older and newer but still same issue. Also the reason why I’m using that version is because I’m doing a Udemy course trying to learn playwright.

I was able to run the npm init playwright command and also ran the npx playwright install separately. No issues, I do have the latest vs code and node/npm. If I get some time I will test on a laptop that only has vs code installed. Can you verify your versions of node and npm if they are not the latest so I can try on my other pc. Or you could just update them to the latest if out of date. Were there any other required versions for the Udemy course? Apologies that this is being a pain, but out of the box it usually works.


NPM version 8.5.1 Nodejs version 12.22.9

pretty sure 16+ is required for PW

Related Discord Threads

AboutQuestionsDiscord ForumBrowser ExtensionTagsQA Jobs

Rayrun is a community for QA engineers. I am constantly looking for new ways to add value to people learning Playwright and other browser automation frameworks. If you have feedback, email luc@ray.run.