← Back to Discord Forum

Enabling widevine component on chrome / webkit

Hello! I'm having some problems enabling the widevine component on chrome / webkit browsers. I was able to enable it on firefox by configuring on playwright.config.js

firefoxUserPrefs: {
        'media.gmp-manager.updateEnabled': true

But not having luck with chrome. Trying the "channel" chrome, I've tried with:

ignoreDefaultArgs: ['--disable-component-update'] and args: ['--disable-web-security', '--enable-widevine'] Neither seems to work. Anyone having this problem as well? Need the component to test some streams.

Also I've noticed that by launching the test with the vscode extension it works. But launching the tests from the CLI or Playwright UI doesn't work.

Thanks in advance!!

This thread is trying to answer question "How can I enable the widevine component on chrome / webkit browsers?"

0 replies

Related Discord Threads

AboutQuestionsDiscord ForumBrowser ExtensionTagsQA Jobs

Rayrun is a community for QA engineers. I am constantly looking for new ways to add value to people learning Playwright and other browser automation frameworks. If you have feedback, email luc@ray.run.