Rayrun
← Back to Discord Forum

Playwright execution at a standstill

jd777_33342posted in #help-playwright
Open in Discord

I am encountering a weird problem the last few days with my Playwright/Typescript project. When I execute my tests in VS Code (cmd line or GUI) it is taking upwards of 3-4 mins before the tests begin to execute. Once the tests trigger they are running at the normal speed and passing, but there is a serious lag before they begin triggering.
Even running the command "npx playwright/test --version" is taking 2 mins to come back with the version number.

Contrast this with my Python/API/Pytest project in VS Code that is running fast and normal.

This is new as of a cpl days ago and I have no idea where to even begin to diagnose it. FWIW I am running Playwright 1.40.1 if that matters.

This thread is trying to answer question "What could be causing the significant delay before Playwright tests execute?"

4 replies

Have you tried debugging to see which actions takes so long?

Yep. The problem is the DeBug window doesnt even open until more than 1 minute after triggering, and then onec its open it doesnt trigger the browser for another 2 mins or so. Again, once the tests start it runs normal speed. So running in DeBug mode doesn't really tell me anything unfortunately

There is cli env variable for debugging and showing in detail all timings

FYI, I had someone else clone my repo and it runs fine for them. Normal. Also when I run node --v it runs in milliseconds, but npm --v takes 2-3 minutes to return anything. I think something is going on, on the NPM side that's corrupting it.

Related Discord Threads

TwitterGitHubLinkedIn
AboutQuestionsDiscord ForumBrowser ExtensionTagsQA Jobs

Rayrun is a community for QA engineers. I am constantly looking for new ways to add value to people learning Playwright and other browser automation frameworks. If you have feedback, email luc@ray.run.