← Back to Discord Forum

Trying to upgrade to 1.39.0 but 1.37.1 persists


When attempting to upgrade to PW 1.39.0 from 1.36.2 I change the version in package.json then run npm install and when running playwright --version the output is 1.37.1

This thread is trying to answer question "Why does the Playwright version remain at 1.37.1 despite trying to upgrade to 1.39.0?"

22 replies
@marble_95: tried this still 1.37.1 for installed version

tried this still 1.37.1 for installed version

I'm very confused

  1. try to remove node_modules folder
  2. run this command npm install -D @playwright/test@latest
  3. run npm i

Did that as well same thing


look, I have 1.38.0

let me update to the latest one

I run the command npm install -D @playwright/test@latest and it's updated


if you run playwright --version what's the output

mine says 1.39.0 in package.json too forgot to mention



maybe you have globally installed playwright?

double checked there, nope

how are you checking version again? npx @playwright/test --version?

npx playwright --version

what does npx @playwright/test --version say?


I just reverted to the 1.38.0 in package.json


@playwright/test and playwright are different things

Related Discord Threads

AboutQuestionsDiscord ForumBrowser ExtensionTagsQA Jobs

Rayrun is a community for QA engineers. I am constantly looking for new ways to add value to people learning Playwright and other browser automation frameworks. If you have feedback, email luc@ray.run.